re = /(?<first>Transaction ID: (?<transId>\w{1,})\.)(.*)(?<second>Reference code: (?<refCode>\w{1,})\.)/m
str = 'Your transaction was successful. Transaction ID: 453712046. Reference code: 1234326. Thank you!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end