import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "-\\K\\d+(?=[^\\d-]|$)";
final String string = "1-title-2\n"
+ "1-title-title-2\n"
+ "1-title-323-32\n"
+ "1-1\n"
+ "2-3\n"
+ "2-33-22";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}