$re = '~-\K\d+(?=[^\d-]|$)~m';
$str = '1-title-2
1-title-title-2
1-title-323-32
1-1
2-3
2-33-22';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);