re = /-\K\d+(?=[^\d-]|$)/m
str = '1-title-2
1-title-title-2
1-title-323-32
1-1
2-3
2-33-22'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end