const regex = /<column\s+name="([^"]+)"\s*>(.*?)<\/column>/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<column\\s+name="([^"]+)"\\s*>(.*?)<\\\/column>', 'gs')
const str = `<column name="bla">some text</column>
<column name="bla">some text
</column>
<column name="bla">some text
</column>
<column name="bla">some text
some text</column>
<column name="bla">some text
some text
some text</column>`;
const subst = `<\1>\2</\1>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);