$re = '/<column\s+name="([^"]+)"\s*>(.*?)<\/column>/s';
$str = '<column name="bla">some text</column>
<column name="bla">some text
</column>
<column name="bla">some text
</column>
<column name="bla">some text
some text</column>
<column name="bla">some text
some text
some text</column>';
$subst = "<\1>\2</\1>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;