#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b\d{2}[-]?\d{3}[-]|\d{3}[-]?|\d{2}[-]?"
Local $sString = "12345678" & @CRLF & _
"12-345-678" & @CRLF & _
"301234567" & @CRLF & _
"30-123-64-56" & @CRLF & _
"1234567" & @CRLF & _
"123-45-67" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")