const regex = /\b\d{2}[-]?\d{3}[-]|\d{3}[-]?|\d{2}[-]?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b\\d{2}[-]?\\d{3}[-]|\\d{3}[-]?|\\d{2}[-]?', 'g')
const str = `12345678
12-345-678
301234567
30-123-64-56
1234567
123-45-67
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}