$re = '/\b\d{2}[-]?\d{3}[-]|\d{3}[-]?|\d{2}[-]?/';
$str = '12345678
12-345-678
301234567
30-123-64-56
1234567
123-45-67
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);