import re
regex = re.compile(r"<(script)([^\/>]*?)>((\s|.)*?)<\/script\s?>", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("<script type=3D\"text/javascript\">hsjQuery =3D window['jQuery']</script>\n\n"
"<script type=3D\"textjavascript\">hsjQuery = 1 / 2</script>\n\n"
"<script type=3D\"text/javascript\"/>hsjQuery = 1 / 2</script>\n\n"
"<script type=\"textjavascript\">asdgsdgs</script>\n\n"
"<script />\n"
"<script>lala</script>")
subst = "<ff-$1 style='display: none;'$2>$3</ff-$1>"
result = regex.sub(subst, test_str)
if result:
print(result)