re = /<(script)([^\/>]*?)>((\s|.)*?)<\/script\s?>/im
str = '<script type=3D"text/javascript">hsjQuery =3D window[\'jQuery\']</script>
<script type=3D"textjavascript">hsjQuery = 1 / 2</script>
<script type=3D"text/javascript"/>hsjQuery = 1 / 2</script>
<script type="textjavascript">asdgsdgs</script>
<script />
<script>lala</script>'
subst = '<ff-$1 style=\'display: none;\'$2>$3</ff-$1>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result