use strict;
my $str = '"status":"delivered":"recipient":"some.name@mail.com":"subject":"Thank you!":"
"status":"delivered":"recipient":"some.middle.name@mail.com":"subject":"Thank you!":"
"status":"delivered":"recipient":"\\"Name Some \\"<some.name@mail.com>":"subject":"Thank you!":"
"status":"delivered":"recipient":"some.name@mail.com, another.name@mail.com, more.names@mail.com subject":"Thank you!":"
"recipient":"\\"different.name@mail.com\\" <different.name@mail.com>, \\"same.name@mail.com\\"<same.name@mail.com>":"subject":"Thank you!":"';
my $regex = qr/\"(?<mail>(\w+\.)*\w+@\w+\.\w+)\"/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}