$re = '/\"(?<mail>(\w+\.)*\w+@\w+\.\w+)\"/m';
$str = '"status":"delivered":"recipient":"some.name@mail.com":"subject":"Thank you!":"
"status":"delivered":"recipient":"some.middle.name@mail.com":"subject":"Thank you!":"
"status":"delivered":"recipient":"\\"Name Some \\"<some.name@mail.com>":"subject":"Thank you!":"
"status":"delivered":"recipient":"some.name@mail.com, another.name@mail.com, more.names@mail.com subject":"Thank you!":"
"recipient":"\\"different.name@mail.com\\" <different.name@mail.com>, \\"same.name@mail.com\\"<same.name@mail.com>":"subject":"Thank you!":"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);