// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)\"(?<mail>(\w+\.)*\w+@\w+\.\w+)\""#).unwrap();
let string = "\"status\":\"delivered\":\"recipient\":\"some.name@mail.com\":\"subject\":\"Thank you!\":\"
\"status\":\"delivered\":\"recipient\":\"some.middle.name@mail.com\":\"subject\":\"Thank you!\":\"
\"status\":\"delivered\":\"recipient\":\"\\\"Name Some \\\"<some.name@mail.com>\":\"subject\":\"Thank you!\":\"
\"status\":\"delivered\":\"recipient\":\"some.name@mail.com, another.name@mail.com, more.names@mail.com subject\":\"Thank you!\":\"
\"recipient\":\"\\\"different.name@mail.com\\\" <different.name@mail.com>, \\\"same.name@mail.com\\\"<same.name@mail.com>\":\"subject\":\"Thank you!\":\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}