using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"java\.lang\.([^\s:]+)";
string input = @"java.lang.OutOfMemoryError: Java heap space Error sending periodic event
java.lang.NullPointerException: Java heap space Error sending periodic event";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}