package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)java\.lang\.([^\s:]+)`)
var str = `java.lang.OutOfMemoryError: Java heap space Error sending periodic event
java.lang.NullPointerException: Java heap space Error sending periodic event`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}