re = /java\.lang\.([^\s:]+)/m
str = 'java.lang.OutOfMemoryError: Java heap space Error sending periodic event
java.lang.NullPointerException: Java heap space Error sending periodic event'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end