#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?=.*#|.*!)(.*)"
Local $sString = "http://WWW.url.com/exemplo/index#" & @CRLF & _
"http://WWW.url.com/#exemplo" & @CRLF & _
"http://WWW.url.com/exemplo!" & @CRLF & _
"http://WWW.url.com/exemplo" & @CRLF & _
"http://WWW.url.com/#!exemplo" & @CRLF & _
"http://WWW.url.com/exemplo#" & @CRLF & _
"http://WWW.url.com/exemplo" & @CRLF & _
"http://idgnow.com.br/internet/2017/07/12/em-queda-acoes-da-snap-ficam-abaixo-do-preco-do-ipo-pela-primeira-vez/" & @CRLF & _
"http://exame.abril.com.br/tecnologia/itau-usara-inteligencia-artificial-para-ter-agencias-mais-seguras/" & @CRLF & _
"http://idgnow.com.br/internet/!2017/07/12/em-queda-acoes-da-snap-ficam-abaixo-do-preco-do-ipo-pela-primeira-vez/" & @CRLF & _
"http://idgnow.com.br/#internet/2017/07/12/em-queda-acoes-da-snap-ficam-abaixo-do-preco-do-ipo-pela-primeira-vez/#"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")