use strict;
my $str = 'http://WWW.url.com/exemplo/index#
http://WWW.url.com/#exemplo
http://WWW.url.com/exemplo!
http://WWW.url.com/exemplo
http://WWW.url.com/#!exemplo
http://WWW.url.com/exemplo#
http://WWW.url.com/exemplo
http://idgnow.com.br/internet/2017/07/12/em-queda-acoes-da-snap-ficam-abaixo-do-preco-do-ipo-pela-primeira-vez/
http://exame.abril.com.br/tecnologia/itau-usara-inteligencia-artificial-para-ter-agencias-mais-seguras/
http://idgnow.com.br/internet/!2017/07/12/em-queda-acoes-da-snap-ficam-abaixo-do-preco-do-ipo-pela-primeira-vez/
http://idgnow.com.br/#internet/2017/07/12/em-queda-acoes-da-snap-ficam-abaixo-do-preco-do-ipo-pela-primeira-vez/#';
my $regex = qr/(?=.*#|.*!)(.*)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}