import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=.*#|.*!)(.*)";
final String string = "http://WWW.url.com/exemplo/index#\n"
+ "http://WWW.url.com/#exemplo\n"
+ "http://WWW.url.com/exemplo!\n"
+ "http://WWW.url.com/exemplo\n"
+ "http://WWW.url.com/#!exemplo\n"
+ "http://WWW.url.com/exemplo#\n"
+ "http://WWW.url.com/exemplo\n"
+ "http://idgnow.com.br/internet/2017/07/12/em-queda-acoes-da-snap-ficam-abaixo-do-preco-do-ipo-pela-primeira-vez/\n"
+ "http://exame.abril.com.br/tecnologia/itau-usara-inteligencia-artificial-para-ter-agencias-mais-seguras/\n"
+ "http://idgnow.com.br/internet/!2017/07/12/em-queda-acoes-da-snap-ficam-abaixo-do-preco-do-ipo-pela-primeira-vez/\n"
+ "http://idgnow.com.br/#internet/2017/07/12/em-queda-acoes-da-snap-ficam-abaixo-do-preco-do-ipo-pela-primeira-vez/#";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}