using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!=.*#|.*!)(.*)";
string input = @"http://WWW.url.com/exemplo/index#
http://WWW.url.com/#exemplo
http://WWW.url.com/exemplo!
http://WWW.url.com/exemplo
http://WWW.url.com/#!exemplo
http://WWW.url.com/exemplo#
http://WWW.url.com/exemplo
http://idgnow.com.br/internet/2017/07/12/em-queda-acoes-da-snap-ficam-abaixo-do-preco-do-ipo-pela-primeira-vez/
http://exame.abril.com.br/tecnologia/itau-usara-inteligencia-artificial-para-ter-agencias-mais-seguras/
http://idgnow.com.br/internet/!2017/07/12/em-queda-acoes-da-snap-ficam-abaixo-do-preco-do-ipo-pela-primeira-vez/
http://idgnow.com.br/#internet/2017/07/12/em-queda-acoes-da-snap-ficam-abaixo-do-preco-do-ipo-pela-primeira-vez/#";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}