const regex = /(?!=.*#|.*!)(.*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!=.*#|.*!)(.*)', 'g')
const str = `http://WWW.url.com/exemplo/index#
http://WWW.url.com/#exemplo
http://WWW.url.com/exemplo!
http://WWW.url.com/exemplo
http://WWW.url.com/#!exemplo
http://WWW.url.com/exemplo#
http://WWW.url.com/exemplo
http://idgnow.com.br/internet/2017/07/12/em-queda-acoes-da-snap-ficam-abaixo-do-preco-do-ipo-pela-primeira-vez/
http://exame.abril.com.br/tecnologia/itau-usara-inteligencia-artificial-para-ter-agencias-mais-seguras/
http://idgnow.com.br/internet/!2017/07/12/em-queda-acoes-da-snap-ficam-abaixo-do-preco-do-ipo-pela-primeira-vez/
http://idgnow.com.br/#internet/2017/07/12/em-queda-acoes-da-snap-ficam-abaixo-do-preco-do-ipo-pela-primeira-vez/#`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}