re = /(?!=.*#|.*!)(.*)/
str = 'http://WWW.url.com/exemplo/index#
http://WWW.url.com/#exemplo
http://WWW.url.com/exemplo!
http://WWW.url.com/exemplo
http://WWW.url.com/#!exemplo
http://WWW.url.com/exemplo#
http://WWW.url.com/exemplo
http://idgnow.com.br/internet/2017/07/12/em-queda-acoes-da-snap-ficam-abaixo-do-preco-do-ipo-pela-primeira-vez/
http://exame.abril.com.br/tecnologia/itau-usara-inteligencia-artificial-para-ter-agencias-mais-seguras/
http://idgnow.com.br/internet/!2017/07/12/em-queda-acoes-da-snap-ficam-abaixo-do-preco-do-ipo-pela-primeira-vez/
http://idgnow.com.br/#internet/2017/07/12/em-queda-acoes-da-snap-ficam-abaixo-do-preco-do-ipo-pela-primeira-vez/#'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end