import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\w*_\\d{1}\\.\\d{1}\\.zip";
final String string = "IDG_COM_UR_PREV_CLT_0.1.zip\n"
+ "IDG_COM_UR_PREV_CLT_0.2.zip\n"
+ "IDG_COM_UR_TEST_0.1.zip\n"
+ "IDG_COM_UR_TEST_0.2.zip\n"
+ "IDG_COM_UR_TEST_TEST_TEST_TEST_TEST_0.1.zip\n"
+ "IDG_COM_UR_TEST_TEST_TEST_TEST_0.2.zip";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}