use strict;
my $str = 'IDG_COM_UR_PREV_CLT_0.1.zip
IDG_COM_UR_PREV_CLT_0.2.zip
IDG_COM_UR_TEST_0.1.zip
IDG_COM_UR_TEST_0.2.zip
IDG_COM_UR_TEST_TEST_TEST_TEST_TEST_0.1.zip
IDG_COM_UR_TEST_TEST_TEST_TEST_0.2.zip';
my $regex = qr/\w*_\d{1}\.\d{1}\.zip/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}