import re
regex = re.compile(r"\w*_\d{1}\.\d{1}\.zip", flags=re.MULTILINE)
test_str = ("IDG_COM_UR_PREV_CLT_0.1.zip\n"
"IDG_COM_UR_PREV_CLT_0.2.zip\n"
"IDG_COM_UR_TEST_0.1.zip\n"
"IDG_COM_UR_TEST_0.2.zip\n"
"IDG_COM_UR_TEST_TEST_TEST_TEST_TEST_0.1.zip\n"
"IDG_COM_UR_TEST_TEST_TEST_TEST_0.2.zip")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")