#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((?:[a-zA-Z0-9-]+\.)+[a-zA-Z0-9-]{2,})$"
Local $sString = "b-app05-06.boldchat.com" & @CRLF & _
"ns126a.ba1.enops.net" & @CRLF & _
"NHQSDFEXCHUB01.nam.coair.com" & @CRLF & _
"ncsmcexchub01.nam.coair.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")