$re = '/((?:[a-zA-Z0-9-]+\.)+[a-zA-Z0-9-]{2,})$/m';
$str = 'b-app05-06.boldchat.com
ns126a.ba1.enops.net
NHQSDFEXCHUB01.nam.coair.com
ncsmcexchub01.nam.coair.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);