re = /((?:[a-zA-Z0-9-]+\.)+[a-zA-Z0-9-]{2,})$/m
str = 'b-app05-06.boldchat.com
ns126a.ba1.enops.net
NHQSDFEXCHUB01.nam.coair.com
ncsmcexchub01.nam.coair.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end