#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\<td\>(.*)\<\/td\>"
Local $sString = " <table>" & @CRLF & _
" <tr>" & @CRLF & _
" <td>Jack</td>" & @CRLF & _
" <td>Peter</td>" & @CRLF & _
" <td>Barmar</td>" & @CRLF & _
" </tr>" & @CRLF & _
" </table>"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)