const regex = /\<td\>(.*)\<\/td\>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\<td\\>(.*)\\<\\\/td\\>', 'g')
const str = ` <table>
<tr>
<td>Jack</td>
<td>Peter</td>
<td>Barmar</td>
</tr>
</table>`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);