# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!\S) (?= )/./gm;t' <<< "foo url1
foobar url2
foo bar url3
"