$re = '/(?<!\S) (?= )/m';
$str = 'foo url1
foobar url2
foo bar url3
';
$subst = ".";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;