re = /(?<!\S) (?= )/m
str = 'foo url1
foobar url2
foo bar url3
'
subst = '.'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result