package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\/dir1(?:\/[^\/\s]+)*`)
var str = `some text /dir1/dir2/ some text
some text /dir1/dir3 some text`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}