re = /\/dir1(?:\/[^\/\s]+)*/m
str = 'some text /dir1/dir2/ some text
some text /dir1/dir3 some text'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end