$re = '/\/dir1(?:\/[^\/\s]+)*/m';
$str = 'some text /dir1/dir2/ some text
some text /dir1/dir3 some text';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);