using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^org.apache.jackrabbit.vault.packaging.impl.ActivityLog\s(?<package_group>.*?)\:(?<package_name>.*?)\:((?P<package_version>.*)\:\sINSTALL|\sINSTALL)";
string input = @"org.apache.jackrabbit.vault.packaging.impl.ActivityLog my_packages:INC1664321_HeaderIssueChanges: INSTALL
org.apache.jackrabbit.vault.packaging.impl.ActivityLog Aldi Content Package Group:aldi-aem.acl-configuration:2022.307.1144904.0001129077: INSTALL";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}