package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^org.apache.jackrabbit.vault.packaging.impl.ActivityLog\s(?<package_group>.*?)\:(?<package_name>.*?)\:((?P<package_version>.*)\:\sINSTALL|\sINSTALL)`)
var str = `org.apache.jackrabbit.vault.packaging.impl.ActivityLog my_packages:INC1664321_HeaderIssueChanges: INSTALL
org.apache.jackrabbit.vault.packaging.impl.ActivityLog Aldi Content Package Group:aldi-aem.acl-configuration:2022.307.1144904.0001129077: INSTALL`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}