// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^org.apache.jackrabbit.vault.packaging.impl.ActivityLog\s(?<package_group>.*?)\:(?<package_name>.*?)\:((?P<package_version>.*)\:\sINSTALL|\sINSTALL)").unwrap();
let string = "org.apache.jackrabbit.vault.packaging.impl.ActivityLog my_packages:INC1664321_HeaderIssueChanges: INSTALL
org.apache.jackrabbit.vault.packaging.impl.ActivityLog Aldi Content Package Group:aldi-aem.acl-configuration:2022.307.1144904.0001129077: INSTALL";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}