using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)(?<![^\W_])active users(?![^\W_])";
string input = @"Active users_test
Test_ACTIVE USERS
AcTiVE Users, active users, ACTIVE USERS";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}