re = /(?i)(?<![^\W_])active users(?![^\W_])/
str = 'Active users_test
Test_ACTIVE USERS
AcTiVE Users, active users, ACTIVE USERS'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end