$re = '/(?i)(?<![^\W_])active users(?![^\W_])/';
$str = 'Active users_test
Test_ACTIVE USERS
AcTiVE Users, active users, ACTIVE USERS';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);