#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:\d+(?:\.\d*)?|\.\d+)$"
Local $sString = "12." & @CRLF & _
"" & @CRLF & _
"12.23" & @CRLF & _
"" & @CRLF & _
".12" & @CRLF & _
"" & @CRLF & _
"0.34" & @CRLF & _
"" & @CRLF & _
"12.@" & @CRLF & _
"" & @CRLF & _
"12.2a"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")