$re = '/^(?:\d+(?:\.\d*)?|\.\d+)$/m';
$str = '12.
12.23
.12
0.34
12.@
12.2a';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);