package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\d+(?:\.\d*)?|\.\d+)$`)
var str = `12.
12.23
.12
0.34
12.@
12.2a`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}