package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)http.*=20$(*SKIP)(*FAIL)|=20`)
var str = `$correspondence = <<<EOF
Hello=20
=20
Thank you for getting back to me.=20
The link you need is http://domain.com/index.php?id=204726 .=20
Regards=20
EOF;`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}