import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "http.*=20$(*SKIP)(*FAIL)|=20";
final String string = "$correspondence = <<<EOF\n"
+ "Hello=20\n"
+ "=20\n"
+ "Thank you for getting back to me.=20\n"
+ "The link you need is http://domain.com/index.php?id=204726 .=20\n"
+ "Regards=20\n"
+ "EOF;";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}