re = /http.*=20$(*SKIP)(*FAIL)|=20/m
str = '$correspondence = <<<EOF
Hello=20
=20
Thank you for getting back to me.=20
The link you need is http://domain.com/index.php?id=204726 .=20
Regards=20
EOF;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end