using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s([A-Z_]+\.)([A-Za-z0-9_]+)";
string substitution = @" MAX(Len(\1\2)) AS \2";
string input = @"SELECT HOSP.TIPO, HOSP.FECHA_INGRESO, HOSP.FECHA_ALTA, HOSP.NHC, HOSP.EPISODIO, HOSP.ID, HOSP.SEXO, HOSP.FNAC, HOSP.MEDICO, HOSP.MUTUA, HOSP.MOTIVO, HOSP.DIAG, HOSP.PROC, HOSP.MES_ALTA, HOSP.ESPECIALIDAD, HOSP.ESTADO
FROM HOSP;
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}